Jump to content


Photo

Opera Browser is needed for viewing Pāli


  • Please log in to reply
4 replies to this topic

#1 Bhikkhu Pesala

Bhikkhu Pesala

    Advanced Member

  • Members
  • PipPipPip
  • 72 posts
  • Location:Seven Kings, East London
  • Interests:Buddhism, Meditation, DTP, Font Editing, Web Publishing

Posted 04 May 2006 - 04:50 PM

To see the full range of accented characters you may also need to install a suitable Unicode font, though most users will have fonts that include the Pāli vowels at least (āīū ĀĪŪ)

For easy typing of Pāli in Opera you can modify the keyboard to add shortcuts to suit your personal needs.

Spell-checking of Pāli text in edit boxes is currently only available by using a free third-party utility to copy the text to Open Office, check it there, and paste it back in when done. The spell-checker used by Opera — Aspell — is capable of checking Unicode text, but this hasn't yet been properly implemented as far as I know.

If you see square boxes below, then you either need to install a Unicode font, or change your browser to Opera or Firefox.

āīūḍḷṃṇṅṭ — ĀĪŪḶṂṆṄṬ

ḥṛṝṣś ḤṚṜṢŚ (Sanskrit)


IPB Image

#2 mike

mike

    Advanced Member

  • Members
  • PipPipPip
  • 38 posts

Posted 05 May 2006 - 01:28 AM

Bhante:

Thanks for this tip. I have two Unicode fonts and still the page does not display properly. There are practical obstacles to my switching browsers so I'll try installing one from the linked page.

Thank you Sir and

Very Pleased to Meet You,

mike

QUOTE(Bhikkhu Pesala @ May 4 2006, 09:50 AM) View Post

To see the full range of accented characters you may also need to install a suitable Unicode font, though most users will have fonts that include the Pāli vowels at least (āīū ĀĪŪ)

For easy typing of Pāli in Opera you can modify the keyboard to add shortcuts to suit your personal needs.

Spell-checking of Pāli text in edit boxes is currently only available by using a free third-party utility to copy the text to Open Office, check it there, and paste it back in when done. The spell-checker used by Opera Aspell is capable of checking Unicode text, but this hasn't yet been properly implemented as far as I know.

If you see square boxes below, then you either need to install a Unicode font, or change your browser to Opera or Firefox.

āīūḍḷṃṇṅṭ ĀĪŪḶṂṆṄṬ

ḥṛṝṣś ḤṚṜṢŚ (Sanskrit)


IPB Image



#3 Bhikkhu Pesala

Bhikkhu Pesala

    Advanced Member

  • Members
  • PipPipPip
  • 72 posts
  • Location:Seven Kings, East London
  • Interests:Buddhism, Meditation, DTP, Font Editing, Web Publishing

Posted 05 May 2006 - 07:14 AM

Pāli fonts do seem to display correctly in Internet Explorer. Perhaps it is just a matter of setting it up correctly. A more serious problem, however, is with the formatting of the page. The GIF animation also does not display, though I have animation checked in Internet Options, Multimedia.

Attached Files



#4 RobertK

RobertK

    Administrator

  • Root Admin
  • 1,321 posts

Posted 05 May 2006 - 08:06 AM

Thanks for all this venerable! So which is better for this forum and pali, firefox or opera?
Could you explain the problem with gif? I will contact invision and get it fixed once I understand what is wrong.

#5 Bhikkhu Pesala

Bhikkhu Pesala

    Advanced Member

  • Members
  • PipPipPip
  • 72 posts
  • Location:Seven Kings, East London
  • Interests:Buddhism, Meditation, DTP, Font Editing, Web Publishing

Posted 05 May 2006 - 08:58 AM

Whatever browser you prefer is best for you. The forum should work with all major browsers if possible:

Internet Explorer, Firefox, Opera, and Safari (for MACS).

As far as I can tell, the only thing that needs to change is to set the table width to "relative" instead of "fixed" to make the forum work in IE. Someone on the Invision Power Board forums could probably help you with that. I wouldn't give any further thought to the GIF animation problem. We don't need it here, though some of the smileys are animated. blink.gif (this shows as a link for me in IE)

I prefer Opera because I can type Pāli easily and it has integrated email. I have never used Firefox.

The forum is working fine for me.